Not you, Linux!

Linux 2.6.x, 3.x, Ubuntu 10, 11, 12, all vulnerable to a race condition within ptrace.

Linux 3.3 to 3.8 vulnerable at netlink messages.

C’mon, Penguin, we always had you as the strongest brother. If you start getting sick, people would get really scared. I mean, zombie apocalypse style.

Edit 1: the race condition / ptrace has some workarounds, that would give you sometime before that “simple” Update-Kernel task… Hiding your Linux from Internet direct connections (could be hard, in some cases) and using strong authentication to all accounts with tokens (could be even harder, plus $$$).

Advertisements